前端程序编译报错,无法运行

bug反馈 未结 10 233
yangchch
yangchch VIP3 2020-09-19 17:47:38   最后修改:2020-09-19 17:48:21
收藏
产品:vue 版本:7.0
img[/userfiles/fly/2097df7fe36747f6b1a1f272999ebafc/files/1600508875036.] img[/userfiles/fly/2097df7fe36747f6b1a1f272999ebafc/files/1600508885115.]
回帖
  • 2020-09-19 17:51:15
    删除node_modules文件夹 重新install
    0 回复
  • 2020-09-19 18:13:29
    已将源代码目录下node_modules 文件佳删除,但是运行后仍然报错
    0 回复
  • 2020-09-19 18:18:20
    cnpm install 报错,采用 npm install安装 PS E:\jeeplus\JeePlusSrc\jp-ui> cnpm install cnpm : 无法加载文件 D:\vueProject\nodejs\node_global\cnpm.ps1,因为在此系统上禁止运行脚本。有关详细信息,请参阅 https:/go.microsoft.com/fwlink/?LinkID=135170 中的 about_Execution_Policies。 所在位置 行:1 字符: 1 + cnpm install + ~~~~ + CategoryInfo : SecurityError: (:) [],PSSecurityException + FullyQualifiedErrorId : UnauthorizedAccess
    0 回复
  • 2020-09-19 18:20:38
    运行命令, npm run serve 后,提示很多错误,如下是其中部分报错信息 [pre] error in ./src/components/numberInfo/NumberInfo.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/postcss-loader/src/index.js): Error: Loading PostCSS Plugin failed: No valid exports main found for 'E:\jeeplus\JeePlusSrc\jp-ui\node_modules\colorette' (@E:\jeeplus\JeePlusSrc\jp-ui\package.json) at load (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:28:11) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:53:16 at Array.map (<anonymous>) at plugins (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:52:8) at processResult (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:33:14) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:94:14 @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader/dist/cjs.js??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/dist/cjs.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/components/numberInfo/NumberInfo.vue?vue&type=style&index=0&lang=scss& 4:14-459 14:3-18:5 15:22-467 @ ./src/components/numberInfo/NumberInfo.vue?vue&type=style&index=0&lang=scss& @ ./src/components/numberInfo/NumberInfo.vue @ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/dashboard/monitor/ActiveChart.vue?vue&type=script&lang=js& @ ./src/views/modules/sys/dashboard/monitor/ActiveChart.vue?vue&type=script&lang=js& @ ./src/views/modules/sys/dashboard/monitor/ActiveChart.vue @ ./src/views sync ^\.\/.*\.vue$ @ ./src/router/import-development.js @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.3.57:3000&sockPath=/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/sys/dashboard/monitor/index.vue?vue&type=style&index=0&id=6657cca4&lang=scss&scoped=true& Module build failed (from ./node_modules/postcss-loader/src/index.js): Error: Loading PostCSS Plugin failed: No valid exports main found for 'E:\jeeplus\JeePlusSrc\jp-ui\node_modules\colorette' (@E:\jeeplus\JeePlusSrc\jp-ui\package.json) at load (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:28:11) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:53:16 at Array.map (<anonymous>) at plugins (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:52:8) at processResult (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:33:14) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:94:14 @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader/dist/cjs.js??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/dist/cjs.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/dashboard/monitor/index.vue?vue&type=style&index=0&id=6657cca4&lang=scss&scoped=true& 4:14-532 14:3-18:5 15:22-540 @ ./src/views/modules/sys/dashboard/monitor/index.vue?vue&type=style&index=0&id=6657cca4&lang=scss&scoped=true& @ ./src/views/modules/sys/dashboard/monitor/index.vue @ ./src/views sync ^\.\/.*\.vue$ @ ./src/router/import-development.js @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.3.57:3000&sockPath=/sockjs-node (webpack)/hot/dev-server.js ./src/main.js [/pre]
    0 回复
  • 2020-09-19 18:39:55
    npm install 提示如下: [pre] E:\jeeplus\JeePlusSrc\jp-ui>npm install > yorkie@2.0.0 install E:\jeeplus\JeePlusSrc\jp-ui\node_modules\yorkie > node bin/install.js setting up Git hooks can't find .git directory, skipping Git hooks installation > core-js@2.6.11 postinstall E:\jeeplus\JeePlusSrc\jp-ui\node_modules\babel-polyfill\node_modules\core-js > node -e "try{require('./postinstall')}catch(e){}" Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: > https://opencollective.com/core-js > https://www.patreon.com/zloirock Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) > core-js@2.6.11 postinstall E:\jeeplus\JeePlusSrc\jp-ui\node_modules\babel-register\node_modules\core-js > node -e "try{require('./postinstall')}catch(e){}" > core-js@2.6.11 postinstall E:\jeeplus\JeePlusSrc\jp-ui\node_modules\babel-runtime\node_modules\core-js > node -e "try{require('./postinstall')}catch(e){}" > core-js@3.6.5 postinstall E:\jeeplus\JeePlusSrc\jp-ui\node_modules\core-js > node -e "try{require('./postinstall')}catch(e){}" > ejs@2.7.4 postinstall E:\jeeplus\JeePlusSrc\jp-ui\node_modules\ejs > node ./postinstall.js Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\webpack-dev-server\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\watchpack-chokidar2\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) added 1715 packages from 1124 contributors in 168.787s 55 packages are looking for funding run `npm fund` for details [/pre]
    0 回复
  • 2020-09-19 18:41:29
    npm run build 部分报错信息如下 [pre] E:\jeeplus\JeePlusSrc\jp-ui>npm run build > jeeplus-ui@1.0.0 build E:\jeeplus\JeePlusSrc\jp-ui > vue-cli-service build / Building for production... ERROR Failed to compile with 63 errors 下午6:37:43 error in ./node_modules/jeeplus-flowable/lib/jeeplus-flowable.css Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js): ModuleBuildError: Module build failed (from ./node_modules/postcss-loader/src/index.js): Error: Loading PostCSS Plugin failed: No valid exports main found for 'E:\jeeplus\JeePlusSrc\jp-ui\node_modules\colorette' (@E:\jeeplus\JeePlusSrc\jp-ui\node_modules\jeeplus-flowable\postcss.config.js) at load (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:28:11) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:53:16 at Array.map (<anonymous>) at plugins (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:52:8) at processResult (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:33:14) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:94:14 at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\webpack\lib\NormalModule.js:316:20 at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\loader-runner\lib\LoaderRunner.js:367:11 at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\loader-runner\lib\LoaderRunner.js:233:18 at context.callback (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\loader-runner\lib\LoaderRunner.js:111:13) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-loader\src\index.js:208:9 @ ./src/main.js 28:0-51 @ multi ./src/main.js error in ./node_modules/jeeplus-form/dist/JpFormMaking.css Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js): ModuleBuildError: Module build failed (from ./node_modules/postcss-loader/src/index.js): Error: Loading PostCSS Plugin failed: No valid exports main found for 'E:\jeeplus\JeePlusSrc\jp-ui\node_modules\colorette' (@E:\jeeplus\JeePlusSrc\jp-ui\node_modules\jeeplus-form\package.json) at load (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:28:11) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:53:16 at Array.map (<anonymous>) at plugins (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\plugins.js:52:8) at processResult (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:33:14) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-load-config\src\index.js:94:14 at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\webpack\lib\NormalModule.js:316:20 at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\loader-runner\lib\LoaderRunner.js:367:11 at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\loader-runner\lib\LoaderRunner.js:233:18 at context.callback (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\loader-runner\lib\LoaderRunner.js:111:13) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\postcss-loader\src\index.js:208:9 [/pre]
    0 回复
  • 2020-09-19 18:59:01
    请先安装cnpm命令
    0 回复
  • 2020-09-19 19:50:22
    cnpm install 安装后,仍然无法运行 [pre] E:\jeeplus\JeePlusSrc\jp-ui>cnpm install - [21/67] Installing tiny-svg@^2.2.2platform unsupported jeeplus-flowable@1.0.25 › sass@1.26.11 › chokidar@3.4.2 › fsevents@~2.1.2 Package require os(darwin) not compatible with your platform(win32) \ [21/67] Installing fill-range@^7.0.1[fsevents@~2.1.2] optional install error: Package require os(darwin) not compatible with your platform(win32) - [37/67] Installing pkg-dir@^1.0.0 WARN node unsupported "node@v13.6.0" is incompatible with @vue/cli-plugin-babel@4.5.6 › @vue/babel-preset-app@4.5.6 › @babel/helper-compilation-targets@7.10.4 › browserslist@^4.12.0, expected node@^6 || ^7 || ^8 || ^9 || ^10 || ^11 || ^12 || >=13.7 / [42/67] Installing url@^0.11.0 WARN node unsupported "node@v13.6.0" is incompatible with @vue/cli-plugin-babel@4.5.6 › webpack@4.44.2 › watchpack@1.7.4 › watchpack-chokidar2@^2.0.0, expected node@<8.10.0 / [42/67] Installing webpack-dev-server@^3.11.0platform unsupported @vue/cli-plugin-babel@4.5.6 › webpack@4.44.2 › watchpack@1.7.4 › watchpack-chokidar2@2.0.0 › chokidar@2.1.8 › fsevents@^1.2.7 Package require os(darwin) not compatible with your platform(win32) [vue-loader-v16@npm:vue-loader@^16.0.0-beta.7] optional install error: Error: Unsupported URL Type: npm:vue-loader@^16.0.0-beta.7 at parseUrl (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\npm-package-arg\npa.js:186:13) at npa (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\npm-package-arg\npa.js:79:12) at _install (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\npminstall\lib\install.js:62:11) at _install.next (<anonymous>) at onFulfilled (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\co\index.js:65:19) at D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\co\index.js:54:5 at new Promise (<anonymous>) at co (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\co\index.js:50:10) at toPromise (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\co\index.js:118:63) at next (D:\vueProject\nodejs\node_global\node_modules\cnpm\node_modules\co\index.js:99:29) [fsevents@^1.2.7] optional install error: Package require os(darwin) not compatible with your platform(win32) √ Installed 67 packages √ Linked 1110 latest versions [1/4] scripts.postinstall core-js@^3.4.2 run "node -e \"try{require('./postinstall')}catch(e){}\"", root: "E:\\jeeplus\\JeePlusSrc\\jp-ui\\node_modules\\_core-js@3.6.5@core-js" Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: > https://opencollective.com/core-js > https://www.patreon.com/zloirock Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) [1/4] scripts.postinstall core-js@^3.4.2 finished in 128ms [2/4] scripts.install @vue/cli-plugin-eslint@4.5.6 › yorkie@^2.0.0 run "node bin/install.js", root: "E:\\jeeplus\\JeePlusSrc\\jp-ui\\node_modules\\_yorkie@2.0.0@yorkie" setting up Git hooks can't find .git directory, skipping Git hooks installation [2/4] scripts.install @vue/cli-plugin-eslint@4.5.6 › yorkie@^2.0.0 finished in 143ms [3/4] scripts.postinstall @vue/cli-plugin-babel@4.5.6 › @vue/cli-service@4.5.6 › webpack-bundle-analyzer@3.9.0 › ejs@^2.6.1 run "node ./postinstall.js", root: "E:\\jeeplus\\JeePlusSrc\\jp-ui\\node_modules\\_ejs@2.7.4@ejs" Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/) [3/4] scripts.postinstall @vue/cli-plugin-babel@4.5.6 › @vue/cli-service@4.5.6 › webpack-bundle-analyzer@3.9.0 › ejs@^2.6.1 finished in 101ms [4/4] scripts.postinstall element-ui@2.13.2 › async-validator@1.8.5 › babel-runtime@6.26.0 › core-js@^2.4.0 run "node -e \"try{require('./postinstall')}catch(e){}\"", root: "E:\\jeeplus\\JeePlusSrc\\jp-ui\\node_modules\\_core-js@2.6.11@core-js" [4/4] scripts.postinstall element-ui@2.13.2 › async-validator@1.8.5 › babel-runtime@6.26.0 › core-js@^2.4.0 finished in 92ms √ Run 4 scripts peerDependencies link diagram-js@0.21.1 in E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_diagram-js-direct-editing@0.19.0@diagram-js-direct-editing unmet with E:\jeeplus\JeePlusSrc\jp-ui\node_modules\diagram-js(6.7.0) peerDependencies link diagram-js@0.21.1 in E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_diagram-js-origin@0.15.2@diagram-js-origin unmet with E:\jeeplus\JeePlusSrc\jp-ui\node_modules\diagram-js(6.7.0) peerDependencies link ajv@4.11.8 in E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_ajv-keywords@1.5.1@ajv-keywords unmet with E:\jeeplus\JeePlusSrc\jp-ui\node_modules\ajv(6.12.5) peerDependencies WARNING sass-loader@^8.0.0 requires a peer of node-sass@^4.0.0 but none was installed peerDependencies WARNING jeeplus-flowable@1.0.25 › jp-bpmn-js-properties-panel@^5.2.7 requires a peer of bpmn-js@^3.x || ^4.x but bpmn-js@6.5.1 was installed peerDependencies WARNING @vue/cli-plugin-babel@4.5.6 › @vue/cli-service@^4.0.5 requires a peer of @vue/compiler-sfc@^3.0.0-beta.14 but none was installed peerDependencies WARNING sass-loader@^8.0.0 requires a peer of fibers@>= 3.1.0 but none was installed deprecate @vue/cli-plugin-babel@4.5.6 › @vue/cli-shared-utils@4.5.6 › request@^2.88.2 request has been deprecated, see https://github.com/request/request/issues/3142 deprecate @vue/cli-plugin-babel@4.5.6 › @vue/cli-shared-utils@4.5.6 › request@2.88.2 › har-validator@~5.1.3 this deprecate @vue/cli-plugin-babel@4.5.6 › @vue/cli-shared-utils@4.5.6 › @hapi/joi@^15.0.1 This version has been deprecated and is no longer supported or maintained deprecate @vue/cli-plugin-babel@4.5.6 › @vue/cli-shared-utils@4.5.6 › @hapi/joi@15.1.1 › @hapi/topo@3.x.x This version has been deprecated and is no longer supported or maintained deprecate @vue/cli-plugin-babel@4.5.6 › @vue/cli-shared-utils@4.5.6 › @hapi/joi@15.1.1 › @hapi/address@2.x.x This version has been deprecated and is no longer supported or maintained deprecate @vue/cli-plugin-babel@4.5.6 › @vue/cli-shared-utils@4.5.6 › @hapi/joi@15.1.1 › @hapi/hoek@8.x.x This version has been deprecated and is no longer supported or maintained deprecate @vue/cli-plugin-eslint@4.5.6 › globby@9.2.0 › fast-glob@2.2.7 › micromatch@3.1.10 › braces@2.3.2 › snapdragon@0.8.2 › source-map-resolve@0.5.3 › urix@^0.1.0 Please see https://github.com/lydell/urix#deprecated deprecate @vue/cli-plugin-eslint@4.5.6 › globby@9.2.0 › fast-glob@2.2.7 › micromatch@3.1.10 › braces@2.3.2 › snapdragon@0.8.2 › source-map-resolve@0.5.3 › resolve-url@^0.2.1 https://github.com/lydell/resolve-url#deprecated deprecate @vue/cli-plugin-eslint@4.5.6 › eslint@3.19.0 › file-entry-cache@2.0.0 › flat-cache@1.3.4 › circular-json@^0.3.1 CircularJSON is in maintenance only, flatted is its successor. deprecate @vue/cli-plugin-babel@4.5.6 › webpack@4.44.2 › watchpack@1.7.4 › watchpack-chokidar2@2.0.0 › chokidar@^2.1.8 Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. deprecate @vue/cli-plugin-babel@4.5.6 › webpack@4.44.2 › watchpack@1.7.4 › watchpack-chokidar2@2.0.0 › chokidar@2.1.8 › fsevents@^1.2.7 fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2. deprecate element-ui@2.13.2 › async-validator@1.8.5 › babel-runtime@6.26.0 › core-js@^2.4.0 core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3. Recently updated (since 2020-09-12): 23 packages (detail see file E:\jeeplus\JeePlusSrc\jp-ui\node_modules\.recently_updates.txt) Today: → @vue/cli-plugin-babel@4.5.6 › @vue/babel-preset-app@4.5.6 › @babel/helper-compilation-targets@7.10.4 › browserslist@4.14.3 › caniuse-lite@^1.0.30001131(1.0.30001132) (13:35:12) √ All packages installed (1404 packages installed from npm registry, used 48s(network 46s), speed 67.06kB/s, json 1177(2.99MB), tarball 0B) [/pre]
    0 回复
  • 2020-09-19 19:51:08
    npm run serve 运行时报错! [pre] E:\jeeplus\JeePlusSrc\jp-ui>npm run serve > jeeplus-ui@1.0.0 serve E:\jeeplus\JeePlusSrc\jp-ui > vue-cli-service serve INFO Starting development server... 98% after emitting CopyPlugin ERROR Failed to compile with 63 errors 下午7:48:31 error in ./node_modules/_jeeplus-flowable@1.0.25@jeeplus-flowable/lib/jeeplus-flowable.css Module build failed (from ./node_modules/_postcss-loader@3.0.0@postcss-loader/src/index.js): Error: Loading PostCSS Plugin failed: No valid exports main found for 'E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_autoprefixer@9.8.6@autoprefixer\node_modules\colorette' (@E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_jeeplus-flowable@1.0.25@jeeplus-flowable\postcss.config.js) at load (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\plugins.js:28:11) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\plugins.js:53:16 at Array.map (<anonymous>) at plugins (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\plugins.js:52:8) at processResult (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\index.js:33:14) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\index.js:94:14 @ ./node_modules/_jeeplus-flowable@1.0.25@jeeplus-flowable/lib/jeeplus-flowable.css 4:14-188 14:3-18:5 15:22-196 @ ./src/main.js @ multi ./node_modules/_webpack-dev-server@3.11.0@webpack-dev-server/client?http://192.168.3.57:3000&sockPath=/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./node_modules/_jeeplus-form@1.3.15@jeeplus-form/dist/JpFormMaking.css Module build failed (from ./node_modules/_postcss-loader@3.0.0@postcss-loader/src/index.js): Error: Loading PostCSS Plugin failed: No valid exports main found for 'E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_autoprefixer@9.8.6@autoprefixer\node_modules\colorette' (@E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_jeeplus-form@1.3.15@jeeplus-form\package.json) at load (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\plugins.js:28:11) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\plugins.js:53:16 at Array.map (<anonymous>) at plugins (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\plugins.js:52:8) at processResult (E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\index.js:33:14) at E:\jeeplus\JeePlusSrc\jp-ui\node_modules\_postcss-load-config@2.1.1@postcss-load-config\src\index.js:94:14 @ ./node_modules/_jeeplus-form@1.3.15@jeeplus-form/dist/JpFormMaking.css 4:14-184 14:3-18:5 15:22-192 @ ./src/main.js @ multi ./node_modules/_webpack-dev-server@3.11.0@webpack-dev-server/client?http://192.168.3.57:3000&sockPath=/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/assets/scss/index.scss [/pre]
    0 回复
  • 2020-09-19 20:03:07
    cnpm update 后如下错误提示 [pre] npm WARN notsup Unsupported engine for browserslist@4.14.3: wanted: {"node":"^6 || ^7 || ^8 || ^9 || ^10 || ^11 || ^12 || >=13.7"} (current: {"node":"13.6.0","npm":"6.14.8"}) npm WARN notsup Not compatible with your version of node/npm: browserslist@4.14.3 npm WARN notsup Unsupported engine for watchpack-chokidar2@2.0.0: wanted: {"node":"<8.10.0"} (current: {"node":"13.6.0","npm":"6.14.8"}) npm WARN notsup Not compatible with your version of node/npm: watchpack-chokidar2@2.0.0 npm WARN @vue/cli-service@4.5.6 requires a peer of @vue/compiler-sfc@^3.0.0-beta.14 but none is installed. You must install peer dependencies yourself. npm WARN bpmn-js-cli@1.4.1 requires a peer of bpmn-js@^1.x || ^2.x || ^3.x || ^4.x || ^5.x || ^6.x but none is installed. You must install peer dependencies yourself. npm WARN sass-loader@8.0.2 requires a peer of node-sass@^4.0.0 but none is installed. You must install peer dependencies yourself. npm WARN sass-loader@8.0.2 requires a peer of fibers@>= 3.1.0 but none is installed. You must install peer dependencies yourself. npm WARN diagram-js-origin@0.15.2 requires a peer of diagram-js@<1.0.0 but none is installed. You must install peer dependencies yourself. npm WARN jp-bpmn-js-properties-panel@5.2.7 requires a peer of bpmn-js@^3.x || ^4.x but none is installed. You must install peer dependencies yourself. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\webpack-dev-server\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\watchpack-chokidar2\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) [/pre]
    0 回复